系统极客一直在努力
专注于操作系统及软件使用教程

Canonical发布Ubuntu 17.10、16.04 LTS和14.04 LTS主要内核更新

在发布 Ubuntu 18.04 LTS(Bionic Beaver)系列操作系统内核更新以缓解最近披露的 Specter Variant 4(CVE-2018-3639)安全漏洞后,Canonical 现在发布了针对 Ubuntu 17.10(Artful Aardvark)、Ubuntu 16.04 LTS(Xenial Xerus)和 Ubuntu 14.04 LTS(Trusty Tahr)操作系统及其官方衍生产品的主要内核更新。

除了解决在 Ubuntu 17.10、Ubuntu 16.04 LTS 和 Ubuntu 14.04 LTS 64 位系统中发现的 Specter Variant 4(CVE-2018-3639)漏洞之外,新的内核更新还修补了其他各种问题,包括:包括 Linux 内核 USBTV007 驱动程序中的双精度错误(CVE-2017-17975),以及 Device Mapper 组件中的争用条件(CVE-2017-18203)问题。

与此同时,还在 Linux 内核的 madvise(2)实现中修补了一个无限循环问题(CVE-2017-18208)、NCPFS实现中存在缓冲区覆盖缺陷(CVE-2018-8822)、F2FS 实现中的竞争条件(CVE-2017-18193)、Hisilicon HNS 以太网设备驱动程序中的缓冲区溢出(CVE-2017-18222),以及 DCCP 协议实现中的空指针引用漏洞(CVE-2018-1130)。

在 Linux 内核的 block 层子系统中也解决了双倍空闲错误(CVE-2018-7480),以及 SAS 驱动程序子系统中的内存泄漏(CVE-2018-7757)问题,x86 机器检查处理程序中的竞争条件(CVE-2018-7995),以及其他组件中的各种其他问题,包括:netfilter 子系统、SCTP协议实现、netlink 子系统、Xen 子系统和蓝牙 HIP 协议实现。

打赏
分享到: 更多 (0)

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏